PDA

Ver Versão Completa : Ajuda Urgênte com Thunder Travando



jeanlima
06-24-2011, 05:32 PM
Srs, estou abrindo esse novo topico pois o meu anterior foi muito visto mais pouco respondido, a situação a sequinte:
Cache funcionando 100%, Lembrando que o servidor Thunder roda virtualizado em uma maquina Core i3 com 12gbs e 2 hds sata2 de 1gb 3 tres placas de rede 1gb, memoria dedicada ao thunder 5gbs 2 partiçoes Sistema com 100gb e Cache com 600gb o uso da maquina não chega a 10% o maximo exigido da memoria foi de 2mb antes do travamento, ja usava o Thunder 3.1 e nunca tive problema ai quiz fazer o upgrade pois devagarzinho minha rede esta aumentando e vou precisar de um cache melhor, minha rede hoje fica no max 20 onlines simultaneos, max 307 Threads ate o momento, mais a maquina insiste em travar apos algumas horas.
Explicações:
Mikrotik 192.168.2.1
MK-Auth 189.43.20.163:3128
Thunder 172.31.255.5:8080
Clientes 192.168.2.0/24
Redirecionamento via Mangle (pois com o nat travava mais rapido)
Desabilitado todas as regras Filter Rules, Nat(exeto MK-Auth) e mascaramento das redes
Todos os clientes com ip fixo sem DHCP e com ARP

Preciso demais da ajuda de vcs pois fiz a besteira de tirar totalmente o outro Thunder e agora estou com esse problema ainda sem solução,
Quem puder me ajudar a solucionar o problema fico muito grato.

Jean Lima
[email protected]

rencaron
06-24-2011, 08:51 PM
Querido Jean,

Por que inventar ? Você é um mestre em virtualização ? Não tenho notícia de que alguem rodasse o Thunder virtualizado.
Não pude me conter nessa resposta, já que vc insistiu......

jeanlima
06-24-2011, 09:16 PM
Querido Jean,

Por que inventar ? Você é um mestre em virtualização ? Não tenho notícia de que alguem rodasse o Thunder virtualizado.
Não pude me conter nessa resposta, já que vc insistiu......

Caro colega trabalho no ramo de informatica e manutenção de maquinas e rede a mais de 15anos, acho que vc esta um pouco atrazado, pois hoje a maioria das grandes empresas ja trabalham ou estão migrando para virtualização, pois com isso se economiza bastante com hardware, energia, implantação, demanda, etc.
Acho que vc observou que eu ja usava outra versão do Thunder nessa mesma maquina virtualizada, nunca tive nenhum problema(mais de Ano) rede para 30 clientes(rede pequena), se vc percebeu a maquina é com 4 nucleos, 12gbs de memoria(1333), 2 hds(Sata2) de 1tb, fonte 600w Real da Gamer, Coller Turbo, onde o processador não passa de 45 graus. os demais software que roda na maquina que e o Mikrotik e o MK-Auth roda sem nenhum problema, so pra lhe explicar acredito eu que o problema dado no thunder seria um loop na rede, acho que vc entende disso, se sim poderia me ajudar em vez de criticar.
Respondendo a sua pergunta sobre virtualização, sim entendo bastante, se vc precisar implantar na sua empresa pode contar comigo.

De qualquer forma muito obrigado pela sua atenção, mais preciso de solução e não critica.
Abs,
Jean Lima

rencaron
06-24-2011, 09:21 PM
Então, colega, não posso te ajudar.... não tenho capacidade para ensinar mestres...
Numa boa, cara.

jeanlima
06-24-2011, 09:30 PM
Caro colega, vc ta levando deste o inicio para o lado da critica, se vc acredita que o Thunder6 não poder funcionar em maquinas virtualizadas mesmo que para uma rede de pequeno porte, seria mais proveitoso se colocasse isso de uma forma mais agradavel e educada, ainda nao sou mestre, ate porque trabalho praticamente com a plataforma windows, meu conhecimento com linux é basico, se fosse mestre não estaria aqui pedindo a ajuda dos colegas aqui do forum.
De qualquer forma valeu por sua tentativa em ajudar, porque eu acho que esse seria o verdadeiro intuito do FORUM.

Abs...

jeanlima
06-24-2011, 09:37 PM
Srs,

So pra ajudar a entender que a maquina nao esta sendo forçada ao extremo vou passar o pico maximo utilizado pelo Thunder:

CPU 13% (4Nucleos 3.20)
Threads 307 (500)
Memoria 2,2 mb (12gbs)
Trafego Lan - 4,85 mb
Trafego Wan - 2,26 mb
Relatorio tirado do TV2

rencaron
06-24-2011, 09:59 PM
Continuando nossa peleja... O que eu quero dizer, colega é que :
1. Todos os softwares que conheço para virtualização tem suas limitações.
2. O Thundercache é um objeto proprietário.
3. Quando uma plataforma é HOMOLOGADA pelos desenvolvedores, ela é divulgada num post fixo.
4. No início, há mais de dois anos, o Luiz Biazus, lançou sua idéia em construir um cache. O Rodrigo Manga foi a pessoa que se interessou de imediato e "casou" com a idéia.
Depois vieram outros, e outros, e outros que de alguma forma contribuiram com o desenvolvimento. Muitos se foram.
5. Seja você a pessoa que vai fazer, para todos, como o MJR, um tutorial de virtualização do thunder. Torço por você.
6. Não acredite em você quando diz que estou somente criticando. Não é verdade.
7. O que se pode fazer para ajudar, num caso como o seu é muitas informações a respeito de todo seu sistema.

Relaxa. Take it easy.

freitascs
06-25-2011, 02:49 AM
amigo verifica as regras do NAT e do MANGLE por aqui tava acontecendo a mesma coisa só foi alterar algumas coisas que parou de travar e o desempenho também melhorou bastante.

rogeriodj
06-25-2011, 08:40 AM
Sem querer criticar, mais como o amigo renarom disse, esse seu esquema não irá funcionar, pois o thunder e todos os outros caches que conheço, não foi feito para ser usado em ambiente virtualizado, pode procurar outros cache semelhantes ao thunder que vc verá que ninguem recomenda o uso em ambiente virtualizado. Simplificando, vc pode virtualizar tudo menos o cache, então coloque essa maquina somente para cache e use outra virtualizando oq vc precisar!!!

jeanlima
06-25-2011, 09:41 AM
Sem querer criticar, mais como o amigo renarom disse, esse seu esquema não irá funcionar, pois o thunder e todos os outros caches que conheço, não foi feito para ser usado em ambiente virtualizado, pode procurar outros cache semelhantes ao thunder que vc verá que ninguem recomenda o uso em ambiente virtualizado. Simplificando, vc pode virtualizar tudo menos o cache, então coloque essa maquina somente para cache e use outra virtualizando oq vc precisar!!!

rogeriodj,
O brigado pela resposta, estou insistindo na virtualização pois como disse ja usava a quase 1 ano o Thunder 3.1 e nunca tive problemas, tenho aqui alguns clientes meus donos de provedores no qual migrei os sistemas deles para virtualizados ate o momento todos funcionando, mais e a primeira vez que estou testando com thunder6, se eu conseguir irei migrar demais clientes, se não estarei colocando outra maquina, so gostaria que um dos desenvolvedores do programa me explicasse se é ou não possivel essa virtualização, mais muito obrigado pela sua opnião e orientação.
Grato,
Jean Lima

mjr88
06-25-2011, 09:53 AM
Thunder 3.1 não pode nem ser comparado ao Thunder 6. A demanda do Thunder 3.1 não chega a 10% da do Thunder 6, já que a eficiência dele também não chega a isso comparado ao Thunder 6.

Não vou mentir pra você, o Thunder 6 é fominha de hardware sim. Mas posto que sua rede é pra 20-30 clientes simultaneos, vou dar uma oportunidade pra questão, rsrs.

Vamos lá:

1º. Você disse que tem 2 HDs de 1TB. Esses HDs são exclusivos pro Thunder? Só pra Cache? Tem um outro separado pro Sistema?
2º. Posta pra gente, como já pediram aí em cima, o redirecionamento que você tá usando (NAT ou Mangle).

Abraço. T+.

jeanlima
06-25-2011, 10:11 AM
Thunder 3.1 não pode nem ser comparado ao Thunder 6. A demanda do Thunder 3.1 não chega a 10% da do Thunder 6, já que a eficiência dele também não chega a isso comparado ao Thunder 6.

Não vou mentir pra você, o Thunder 6 é fominha de hardware sim. Mas posto que sua rede é pra 20-30 clientes simultaneos, vou dar uma oportunidade pra questão, rsrs.

Vamos lá:

1º. Você disse que tem 2 HDs de 1TB. Esses HDs são exclusivos pro Thunder? Só pra Cache? Tem um outro separado pro Sistema?
2º. Posta pra gente, como já pediram aí em cima, o redirecionamento que você tá usando (NAT ou Mangle).

Abraço. T+.

O primeiro HD serve para os 3 sistemas (Thunder6, MK-Aunth, Mikrotik) sendo: Thunder 6 - 300gbs, Mikrotik -
50gbs - mk-auth 100gbs
o segundo hd serve so para o cache do Thunder6 1tb

Uso redirecionamento via mangle pois via nat o travamento era mais rapido, regras:
/ip firewall mangle
add action=mark-routing chain=prerouting comment="Redirecionamento thunder" \
disabled=no dst-port=80 new-routing-mark=thunder-route passthrough=yes \
protocol=tcp src-address=192.168.2.3-192.168.2.199 src-address-list=\
!NO_PROXY
add action=mark-connection chain=postrouting comment=\
"MARCA CONEXAO COM HIT DO THUNDER" disabled=no dscp=18 dst-address=\
192.168.2.3-192.168.2.199 new-connection-mark=thunder-conn-HIT \
passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting comment=\
"MARCA PACOTES COM HIT DO THUNDER" connection-mark=thunder-conn-HIT \
disabled=no new-packet-mark=thunder-packet-HIT passthrough=yes
add action=mark-connection chain=prerouting comment="Controle P2P" disabled=\
no new-connection-mark=p2p-connection p2p=all-p2p passthrough=yes
add action=mark-connection chain=output comment=\
"Deixar o winbox fora do controle de banda" disabled=no \
new-connection-mark=winbox-out passthrough=yes protocol=tcp src-port=8291
add action=mark-packet chain=output comment="" connection-mark=winbox-out \
disabled=no new-packet-mark=winbox-out passthrough=yes

Mikrotik 3.30
regras no nat:
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes
add action=dst-nat chain=dstnat comment="PG CORTE" disabled=no dst-port=\
0-65535 protocol=tcp src-address=0.0.0.0/0 src-address-list=pgcorte \
to-addresses=189.43.20.163 to-ports=85
add action=dst-nat chain=dstnat comment="AVISO MANUTENCAO" disabled=yes \
dst-port=80 protocol=tcp src-address=0.0.0.0/0 src-address-list=\
manutencao to-addresses=189.43.20.163 to-ports=89
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
disabled=no dst-address=!189.43.20.163 out-interface=Link src-address=\
172.31.255.0/24
add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link \
src-address=192.168.2.0/24
add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link \
src-address=189.43.20.161

Obrigado pela sua atenção.

mjr88
06-25-2011, 10:19 AM
É realmente com um disco só pra cache, não vai ser fácil. Recomendo a você usar no mínimo 2 HDs de cache pro thunder.

Como é o travamento? Para só a navegação? Ou para o acesso SSH e WEB também?

jeanlima
06-25-2011, 10:29 AM
Para a navegação ate tirar o redirecionamento, o SSH funciona e consigo ping na interface da thunder.
Consigo restart thunder
não consigo restart Networking e nem banco de dados
ai so reiniciando a maquina por completo pra voltar ao normal

ferreira
06-25-2011, 10:35 AM
Acompanhando...

freitascs
06-25-2011, 10:53 AM
testa essas regras aqui e ver se dar certo por que eu passei pelo mesmo problema de ficar travando mais engraçado que eu conseguia pingar pro thundercache mais ele parava de fazer cache e não entrava no thunderview na WEB dai peguei essas regras minhas e fiz algumas modificações e ficou 100% e o desempenho melhor bastante.

/ip firewall address lists
add Name=NO_CACHE Address=10.1.1.2


REDIRECIONAMENTO PARA O THUNDERCACHE

/ip firewall nat
add action=dst-nat chain=pre-hotspot comment="REDIRECIONAMENTO PARA O THUNDERCACHE" disabled=no \
dst-port=80 hotspot=auth protocol=tcp src-address=192.168.254.0/24 dst-address-list="!NO_CACHE" to-addresses=\
10.1.1.2 to-ports=8080


CACHE FULL THUNDERCACHE + MIKROTIK essa regras aqui elas tem que fica cima de todas as regras no mangle e você tem usar DCSP (TOS) 18

/ip firewall mangle
add action=mark-connection chain=forward comment="CACHE FULL X:HITS" content=\ usa DSCP (TOS) 18 nessa regra aqui
"X-Cache: HIT" disabled=no new-connection-mark=forward-hits passthrough=\
yes
add action=mark-packet chain=forward comment="" connection-mark=forward-hits \
disabled=no new-packet-mark=cache-hits passthrough=no
add action=mark-connection chain=postrouting comment="THUNDER CACHE 6" \ usa DSCP (TOS) 18 nessa regra aqui
content="X-Cache: HIT from Thunder" disabled=no new-connection-mark=\
thunder6-connection passthrough=yes
add action=mark-packet chain=postrouting comment="" connection-mark=\
thunder6-connection disabled=no new-packet-mark=thunder6-packs \
passthrough=no

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M max-limit=4M name=ThunderCache6 packet-mark=thunder6-packs parent=global-out \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M max-limit=4M name="Thunder cache" packet-mark=cache-hits parent=\
global-out priority=2 queue=default


DESATIVA E ATIVA REGRA NAT AUTOMATICO SE O THUNDERCACHE PARAR DAI A INTERNET VOLTA A FUNCIONAR SEM O THUNDER

/tool netwatch
add comment="" disabled=no down-script="/ip firewall nat { disable 21 }" host=\
ip_do_seu_Thunder interval=5s timeout=1s up-script=\
"/ip firewall nat { enable 21 }"

EM ENABLE 21 VOCÊ BOTA O NUMERO DA POSIÇÃO QUE TA A REGRA DE REDIRECIONAMENTO DO THUNDER

espero que te ajude amigo depois posta ai se resolveu.

jeanlima
06-25-2011, 11:01 AM
testa essas regras aqui e ver se dar certo por que eu passei pelo mesmo problema de ficar travando mais engraçado que eu conseguia pingar pro thundercache mais ele parava de fazer cache e não entrava no thunderview na WEB dai peguei essas regras minhas e fiz algumas modificações e ficou 100% e o desempenho melhor bastante.

REDIRECIONAMENTO PARA O THUNDERCACHE

/ip firewall nat
add action=dst-nat chain=pre-hotspot comment="REDIRECIONAMENTO PARA O THUNDERCACHE" disabled=no \
dst-port=80 hotspot=auth protocol=tcp src-address=192.168.254.0/24 dst-address-list="!NO_CACHE" to-addresses=\
10.1.1.2 to-ports=8080


CACHE FULL THUNDERCACHE + MIKROTIK essa regras aqui elas tem que fica cima de todas as regras no mangle e você tem usar DCSP (TOS) 18

/ip firewall mangle
add action=mark-connection chain=forward comment="CACHE FULL X:HITS" content=\ usa DSCP (TOS) 18 nessa regra aqui
"X-Cache: HIT" disabled=no new-connection-mark=forward-hits passthrough=\
yes
add action=mark-packet chain=forward comment="" connection-mark=forward-hits \
disabled=no new-packet-mark=cache-hits passthrough=no
add action=mark-connection chain=postrouting comment="THUNDER CACHE 6" \ usa DSCP (TOS) 18 nessa regra aqui
content="X-Cache: HIT from Thunder" disabled=no new-connection-mark=\
thunder6-connection passthrough=yes
add action=mark-packet chain=postrouting comment="" connection-mark=\
thunder6-connection disabled=no new-packet-mark=thunder6-packs \
passthrough=no

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M max-limit=4M name=ThunderCache6 packet-mark=thunder6-packs parent=global-out \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M max-limit=4M name="Thunder cache" packet-mark=cache-hits parent=\
global-out priority=2 queue=default


DESATIVA E ATIVA REGRA NAT AUTOMATICO SE O THUNDERCACHE PARAR DAI A INTERNET VOLTA A FUNCIONAR SEM O THUNDER

/tool netwatch
add comment="" disabled=no down-script="/ip firewall nat { disable 21 }" host=\
ip_do_seu_Thunder interval=5s timeout=1s up-script=\
"/ip firewall nat { enable 21 }"

EM ENABLE 21 VOCÊ BOTA O NUMERO DA POSIÇÃO QUE TA A REGRA DE REDIRECIONAMENTO DO THUNDER

espero que te ajude amigo depois posta ai se resolveu.

freitascs,
Obrigado pela sua ajuda, mais tentei essas regra com redirecionamento via nat como o seu, ficou pior ou seja hoje pelo mangle ele ainda funciona entorno de 13 horas via nat não passa de 3horas.
Outra coisa ja uso o tool netwatch mais não tem funcionalidade nesse meu caso pois o ping continua funcionando, so para porta 80,8080 entre outras o ping vai por outro protocolo e não tcp que e o que trava, entao quando trava eu tenho que ir no mangle e desativar o redirecionamento manualmente.

mjr88
06-25-2011, 11:03 AM
Pra mim isso é HD não dando conta das requisições. Poderia ser placa de rede também, mas como é virtualizado, acho meio difícil.

Coloca um outro HD pros sitemas, Mikrotik + MK-Auth + Thunder e deixa esses 2 de 1TB pra cache. Além disso não vejo outra alternativa.

Outra coisa, que você pode tentar, é aumentar a memória pro Thunder, já que Mikrotik e MK-Auth não precisa de muita, 1GB pros 2 já deve ser suficiente se usar o MK-Auth só pra Radius. Quanto mais memória, menos acessos aos discos.

freitascs
06-25-2011, 11:07 AM
então é só você ir em Route e criar uma regra New route em Gerenal Gateway= Ip do thunder em Check Gateway= Ping em Routing Mark thunder-route se o seu thunder parar ele desativa e ativa a regra do seu mangle. mais ele tiver pigando não vai adianta

jeanlima
06-25-2011, 11:38 AM
Pra mim isso é HD não dando conta das requisições. Poderia ser placa de rede também, mas como é virtualizado, acho meio difícil.

Coloca um outro HD pros sitemas, Mikrotik + MK-Auth + Thunder e deixa esses 2 de 1TB pra cache. Além disso não vejo outra alternativa.

Outra coisa, que você pode tentar, é aumentar a memória pro Thunder, já que Mikrotik e MK-Auth não precisa de muita, 1GB pros 2 já deve ser suficiente se usar o MK-Auth só pra Radius. Quanto mais memória, menos acessos aos discos.

Aqui são 3 placas 1gb, e ja testei com as tres, vou tentar colocar outro hd, o hd tem quer ser do mesmo tamanho ou pode ser menor tipo 500gbs?

mjr88
06-25-2011, 11:48 AM
Pode ser de tamanho diferentes, apesar que recomendaria tamanhos iguais pra padronização. Na verdade, prefiro os de 500gb que os de 1tb

iTenneT
06-25-2011, 07:09 PM
Desculpa a pergunta, se parece muito elementar, amigo. Vc está usando já na rede ou testando? Ele trava mesmo, ou ou apenas interrompe o serviço, e tem que reiniciar o serviço no painel?
Abraço.

jeanlima
06-25-2011, 08:59 PM
Desculpa a pergunta, se parece muito elementar, amigo. Vc está usando já na rede ou testando? Ele trava mesmo, ou ou apenas interrompe o serviço, e tem que reiniciar o serviço no painel?
Abraço.

Oi,
Ja estou usando, trava a rede o sitema continua, a navegação não e os serviços tambem não, nao consigo acessar TV2 via web, ai so reiniciando - Reboot, mais fica sempre travado em algum serviço as vezes no thunder as vezes no banco de dados ou networking. ai so desligando e religando pra voltar ao normal.
Ja coloquei mais 1 hd, mais ainda travou, estou trocando os hubs e cabos pra ver se melhora, ainda em teste.
O brigado pelo seu interesse.
Valeu!

fabioccoelho
06-26-2011, 04:14 PM
Também estou com esse mesmo problema, e não uso VM's. Do nada toda a rede para de funcionar, até mesmo o roteador. Quando desabilito o redirecionamento para o Thunder na tabela nat e no mangle, tudo funciona normal.

Estou usando um server com Mikrotik Level 4 e um outro server para o Thunder, com 4 Hd's (sendo um para o sistema separadamente), processador i3 e 8GB de RAM.

[ ]'s

snake_jp
06-26-2011, 07:21 PM
mesmo problema aqui. parando e deixando toda rede off

freitascs
06-26-2011, 10:52 PM
Caro amigos acho que o problema do thunder parar do nada deve ser lá na BMSOFTWARE por que aqui meu thunder tava dois dias funcionando que é um beleza e parou do nada hoje sem ser mexido eu nem tava em casa só recebi uma ligação de um cliente de que a internet tinha caído dai acessei meu MK pelo Winbox da casa da minha sogra e desativei as regras do NAT dai o cliente falo que tinha voltado a internet, ta acontendo igual o dos amigos que estão tendo problema engraçado que consigo pingar pro o ip do thunder mais para de fazer cache a internet para de funcionar e não acessa o ThunderView dai reinicia o PC Thundercache ai tudo volta ao normal, espero que alguem saiba o que ta acontecendo por que isso ta acontecendo com a maioria do pessoal que ta usando o Thundercache 6.

fabioccoelho
06-26-2011, 11:19 PM
Não sei se o problema pode estar atribuído á tráfego na rede ou se é mesmo problema no Thunder. O fato é que já testei todas as regras de NAT e Mangle possíveis, e nenhuma
delas está me servindo.

Vamos esperar pela resposta do Mário ou de outrém da equipe do Thunder.

[ ]'s

freitascs
06-26-2011, 11:41 PM
aqui as regras do NAT e MANGLE estão servindo e funcionando 100% só que parece que está tendo uma epidemia de thunder para do nada inclusive cheguei agora em casa e o thunder que tinha parado de funcionar voltou a funcionar sozinho agora vai intender isso.

fabioccoelho
06-26-2011, 11:43 PM
aqui as regras do NAT e MANGLE estão servindo e funcionando 100% só que parece que está tendo uma epidemia de thunder para do nada inclusive cheguei agora em casa e o thunder que tinha parado de funcionar voltou a funcionar sozinho agora vai intender isso.

Sim, as regras funcionam, mas ao meu ver, são elas que estão fazendo o Thunder parar. Ontém fiz um teste sem o redirect para o Thunder, e não parou um só minuto.

freitascs
06-26-2011, 11:53 PM
concordo com você que o problema pode até está nas regras por que o meu thunder tava travando quando tava usando umas regras postadas aqui no forum mais depois que eu conseguir fazer uma modificações o thunder parou de travar e até mesmo melhorou o desempenho do thunder bastante por que antes de mudar as regras tinha site que não estava abrindo não estava conseguindo fazer downloads depois de mudar algumas coisas nas regras voltou a fazer download, sites que não estavam abrindo começaram a funcionando normal e o desempenho exelente, mais a coisa ta estranho poe que o meu thunder tava dois dias rodando 100% e hoje ele parou e depois de algumas horas ele voltou a funcionar sozinho.

fabioccoelho
06-27-2011, 12:06 AM
concordo com você que o problema pode até está nas regras por que o meu thunder tava travando quando tava usando umas regras postadas aqui no forum mais depois que eu conseguir fazer uma modificações o thunder parou de travar e até mesmo melhorou o desempenho do thunder bastante por que antes de mudar as regras tinha site que não estava abrindo não estava conseguindo fazer downloads depois de mudar algumas coisas nas regras voltou a fazer download, sites que não estavam abrindo começaram a funcionando normal e o desempenho exelente, mais a coisa ta estranho poe que o meu thunder tava dois dias rodando 100% e hoje ele parou e depois de algumas horas ele voltou a funcionar sozinho.

Os ativos (switches e servidores) devem ter um bom desempenho na rede, pois os dados (vídeos, arquivos, etc) em cache saem pela rede sem o controle de banda padrão, e nesse momento poderá congestionar toda a rede. Pode ser isso que esteja acontecendo.

freitascs
06-27-2011, 12:21 AM
não é isso não por que se fosse congestionamento da rede na hora que pingo pro thundercache não éra pra ficar 1ms e sim éra pra dar pings muito altos e até mesmo perda de resposta mais fica 1ms direto então o problema é outro, aqui não uso switch uso direto na RB450 e direto pro meu notebook e outra coisa ele acaba de parar de novo e pingo pro thundercache e a resposta continua 1ms.

jeanlima
06-27-2011, 02:08 PM
Pra resolver meu problema, formatei meu servidor, fiz a configuração do zero, mudei o thunder pra uma maquina separada(temporariamente), e ate agora tudo ok ja se passaram 12horas.

fabioccoelho
06-27-2011, 02:11 PM
Pra resolver meu problema, formatei meu servidor, fiz a configuração do zero, mudei o thunder pra uma maquina separada(temporariamente), e ate agora tudo ok ja se passaram 12horas.

Já fiz tudo isso e o problema persiste... tá complicado.

freitascs
06-27-2011, 02:14 PM
amigo eu fiz algumas modificações ontem e já ta a mais 16 horas e nada de travamento até agora ta rodando filé, vamos acompanhar o andamento.

fabioccoelho
06-27-2011, 02:20 PM
amigo eu fiz algumas modificações ontem e já ta a mais 16 horas e nada de travamento até agora ta rodando filé, vamos acompanhar o andamento.

Quais modificações você fez? Poderia postar aqui?

[ ]'s

freitascs
06-27-2011, 02:34 PM
bom fiz tanta coisa que nem me recordo de tudo por que fiquei quebrando a cabeça mais vai algumas dicas, fui no painel da BMSOFTWARE e botei Threads iniciais 50 por que meu plano só libera isso, depois fui em SCONFIGURANDO SEM TPROXY e retirei todos os IPs que tinha lá, agora no meu Mikrotik eu usava regras de loadbalance dai como só estou com um link eu limpei tudo e refiz toda configuração de internet pro mikrotik só deixando o hotspot dos meus clientes, ai quando criei o PPPeO que disca meu modem eu marquei as opções Add Default Route e Use Peer DNS pronto ficou filé até os site mercadolivre, globo e outros que não estavam abrindo voltaram funcionar.

fabioccoelho
06-27-2011, 02:37 PM
bom fiz tanta coisa que nem me recordo de tudo por que fiquei quebrando a cabeça mais vai algumas dicas, fui no painel da BMSOFTWARE e botei Threads iniciais 50 por que meu plano só libera isso, depois fui em SCONFIGURANDO SEM TPROXY e retirei todos os IPs que tinha lá, agora no meu Mikrotik eu usava regras de loadbalance dai como só estou com um link eu limpei tudo e refiz toda configuração de internet pro mikrotik só deixando o hotspot dos meus clientes, ai quando criei o PPPeO que disca meu modem eu marquei as opções Add Default Route e Use Peer DNS pronto ficou filé até os site mercadolivre, globo e outros que não estavam abrindo voltaram funcionar.

Ah, beleza. Entendi :) .. obrigado.

eduardsp
07-27-2011, 03:24 PM
Pessoal, estou com um servidor core 2 quad com 8 Gb de memoria, 1 HD de 1TB e placa de rede giga, reparei que o trafego passar de 30 megas o processamento começa a subir muito até colar em 100%, hoje ele morre passando banda de 45megas e estorou as 5007 threads do ADS. Minha pergunta é a seguinte, qual a maquina que preciso e qual o plano que preciso para passar essa banda?

eeemk
07-27-2011, 05:27 PM
Não deu pra ler todos os posts, mas só pra deixar um caso de sucesso com virtualização.
Quando comecei a usar o thunder6 aqui na empresa eu usei um server virtualizado encima de um esxi. Coloquei 4 núcleos 2.6GHz + 24GB de memoria pra essa maquina, usei 2 HDs SATA e consegui passar uma parte da minha rede sem problemas. Tive cerca de 700 clientes online durante 1 semana sem nenhum problema de lentidao.

Agora com meu server "novo" o thunder é o gateway da minha rede inteira, cerca 1700 usuarios online com o load em 6.0 na media. Até uns dois dias atras o meu load ficava acima de 100 o tempo todo. Conversando com o Mario e com o Luiz eles me passaram um tunning pro sysclt que funcionou blz.

rodrigomanga
07-27-2011, 06:17 PM
o seu problema é travamento? que tipo de travemento? o que acontece exatamente quando trava?

eu já usei thunder virtualizado, mas quem entende mais desse tipo de ambiente, consegue tirar leite de pedra. Então vamos tentar ajudar ao invés de atrapalhar.

eduardsp
07-27-2011, 08:01 PM
Não deu pra ler todos os posts, mas só pra deixar um caso de sucesso com virtualização.
Quando comecei a usar o thunder6 aqui na empresa eu usei um server virtualizado encima de um esxi. Coloquei 4 núcleos 2.6GHz + 24GB de memoria pra essa maquina, usei 2 HDs SATA e consegui passar uma parte da minha rede sem problemas. Tive cerca de 700 clientes online durante 1 semana sem nenhum problema de lentidao.

Agora com meu server "novo" o thunder é o gateway da minha rede inteira, cerca 1700 usuarios online com o load em 6.0 na media. Até uns dois dias atras o meu load ficava acima de 100 o tempo todo. Conversando com o Mario e com o Luiz eles me passaram um tunning pro sysclt que funcionou blz.

No tunning o que foi alterado no sysclt? vc pode postar aqui?

Pirigoso
07-27-2011, 08:06 PM
cara é so colocar mais hd que seu problema ta resolvido, 1 hd pra os e um pra cache é isso mesmo lentidao na certa apos 1 mes de uso, no minimo 6 HDs turma!

eduardsp
07-27-2011, 08:06 PM
o seu problema é travamento? que tipo de travemento? o que acontece exatamente quando trava?

eu já usei thunder virtualizado, mas quem entende mais desse tipo de ambiente, consegue tirar leite de pedra. Então vamos tentar ajudar ao invés de atrapalhar.

Rodrigo, no meu caso é o consumo fica em 100% e as threads fica no limite liberado para o Thunder ADS, com o consumo de banda de 45 megas, pode ser feito alguma coisa para melhorar?
O servidor que descrevi nesse tópico atende esse trafego? Qual o plano que eu teria que contratar?

rodrigomanga
07-27-2011, 08:17 PM
provavelmente ta travando por excesso de conexões. o trafego parece ser baixo, porém, deve estar com algum virus na sua rede pra consumir todas as threads.

verifique o log, pra vc ver se tem requisições repetidas demais.

eduardsp
07-27-2011, 08:24 PM
provavelmente ta travando por excesso de conexões. o trafego parece ser baixo, porém, deve estar com algum virus na sua rede pra consumir todas as threads.

verifique o log, pra vc ver se tem requisições repetidas demais.

Há alguma forma de bloquear as requisições repetidas, se tiver na minha rede?

fabiandr
07-30-2011, 09:55 AM
buen dia! tengo problemas con el thunder, al principio pense que era que estaba cerca del limite de threads, lo subi contratando otro plan y el problema persiste, en los archivos logs, encontre lo siguiente

1311940439 24468 127.0.0.1 NONE/500 0 0 GET pageinxt.com/?dn=blogdam.net&flrdr=yes&nxte=jpg (pageinxt.com) () 0
1311940439 24473 127.0.0.1 NONE/500 0 0 GET pageinxt.com/?dn=blogdam.net&flrdr=yes&nxte=jpg (pageinxt.com) () 0
1311940439 24477 127.0.0.1 NONE/500 0 0 GET pageinxt.com/?dn=blogdam.net&flrdr=yes&nxte=jpg (pageinxt.com) () 0
1311940439 24479 127.0.0.1 NONE/500 0 0 GET pageinxt.com/?dn=blogdam.net&flrdr=yes&nxte=jpg (pageinxt.com) () 0
1311940439 24478 127.0.0.1 NONE/500 0 0 GET pageinxt.com/?dn=blogdam.net&flrdr=yes&nxte=jpg (pageinxt.com) () 0
1311940439 24480 127.0.0.1 NONE/500 0 0 GET pageinxt.com/?dn=blogdam.net&flrdr=yes&nxte=jpg (pageinxt.com) () 0
1311940439 24482 127.0.0.1 NONE/500 0 0 GET pageinxt.com/?dn=blogdam.net&flrdr=yes&nxte=jpg (pageinxt.com) () 0
1311940439 24485 127.0.0.1 NONE/500 0 0 GET pageinxt.com/?dn=blogdam.net&flrdr=yes&nxte=jpg (pageinxt.com) () 0

esto se repite infinitamente hasta que el thunder se traba, para que vuelva a funcionar hay que reiniciar la pc o desde telnet /etc/init.d/thunder restart, y vuleve a la normalidad, por un tiempo.

que puede ser?

mjr88
07-30-2011, 09:58 AM
É Vírus na rede, amigo.

Se você usa Mikrotik, crie uma regra de Drop na chain forward pra esse endereço "pageinxt.com", e coloque ele fora da regra de redir colocando na address list NO_CACHE.

fabiandr
07-30-2011, 01:59 PM
É Vírus na rede, amigo.

Se você usa Mikrotik, crie uma regra de Drop na chain forward pra esse endereço "pageinxt.com", e coloque ele fora da regra de redir colocando na address list NO_CACHE.

Muchas Gracias! lo voy a implementar, luego les cuento

claudinhohw
02-15-2012, 08:29 PM
bom meu primeiro post e já vou perguntar meu thunder tbm tá travando as vezes tem alguma solução facio pra isso tudo? regras para virus, redirecionamento etc. que funcione corretamente.

claudinhohw
02-15-2012, 08:33 PM
outra coisa! no painel da bm em Controle de Threads
Threads iniciais: qual o valor que tem que ficar eu coloquei 5007! tá certo? eu uso a versão free.

Luiz Biazus
02-15-2012, 11:01 PM
nao precisa botar nenhum vamor mais em threads é completamente dinamico no tc7

Luiz Biazus
02-15-2012, 11:02 PM
pode ser que trava porque vc tem loadbalancer se sim deixa a faixa 177.67.224.0/21 e 189.10.202.0/24 sair por apenas um ip

claudinhohw
02-16-2012, 09:16 AM
pode ser que trava porque vc tem loadbalancer se sim deixa a faixa 177.67.224.0/21 e 189.10.202.0/24 sair por apenas um ip

eu estava usando loadbalance sim o pcc mais agora é só uma rede simples como fica nos dois casos tenho que fazer alguma regra nova em ambos os casos?

Luiz Biazus
02-16-2012, 09:55 AM
apenas quando usa loadbalancer como lhe disse

claudinhohw
02-16-2012, 10:47 AM
apenas quando usa loadbalancer como lhe disse

certo muito obrigado e como eu faço pra sair apenas por um link uso adsl e o mk discando descupe minha perguntas podem parecer tolas mais e que to apredendo!