Resultados 1 a 7 de 7

Tópico: Controle Qos de torrent

  1. #1
    Member
    Data de Ingresso
    Jul 2012
    Posts
    72
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    1

    Controle Qos de torrent

    Pessoal,

    não estou conseguindo limitar o download de torrent, ja tentei de diversas formas, deixei aqui com controle de p2p de saída e entrada, mas o torrent não entra na regra, alguém pode ajudar?

    /queue type
    set default kind=pfifo name=default pfifo-limit=50
    set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50
    set wireless-default kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=\
    5
    set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 \
    red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
    set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
    add kind=pcq name=Thunder pcq-burst-rate=0 pcq-burst-threshold=0 \
    pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
    pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=6M pcq-src-address-mask=32 \
    pcq-src-address6-mask=128 pcq-total-limit=2000
    set only-hardware-queue kind=none name=only-hardware-queue
    set multi-queue-ethernet-default kind=mq-pfifo mq-pfifo-limit=50 name=\
    multi-queue-ethernet-default
    set default-small kind=pfifo name=default-small pfifo-limit=10
    /queue simple
    add burst-limit=0/4M burst-threshold=0/0 burst-time=8s/8s direction=both \
    disabled=no interface="velox 15 mb bridge" limit-at=0/0 max-limit=0/3M \
    name=queue1 parent=none priority=8 queue=default-small/default-small \
    total-queue=default-small
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=30M \
    max-limit=30M name=THUNDER packet-mark=thunder_packs parent=global-out \
    priority=8 queue=Thunder
    add burst-limit=4M burst-threshold=0 burst-time=5s disabled=no limit-at=2M \
    max-limit=2M name=Facebook packet-mark=facebook-packs parent=global-out \
    priority=8 queue=default
    add burst-limit=4M burst-threshold=0 burst-time=5s disabled=no limit-at=2M \
    max-limit=2M name=Orkut packet-mark=orkut-packs parent=global-out priority=\
    8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=100k name=p2p_in packet-mark=p2p_in parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=80k name=p2p_out packet-mark=p2p_out parent=global-out priority=8 \
    queue=default



    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Redireciona Thunder" \
    disabled=no dst-address-list=!Sem-Cache dst-port=80 new-connection-mark=\
    conexoes_thunder passthrough=yes protocol=tcp src-address-list=\
    Rede-Clientes
    add action=mark-routing chain=prerouting comment="Rota Conexoes Thunder" \
    connection-mark=conexoes_thunder disabled=no dst-address-list=!Sem-Cache \
    new-routing-mark=rota_conexoes_thunder passthrough=no src-address-list=\
    Rede-Clientes
    add action=mark-connection chain=prerouting comment="regras p2p" disabled=no \
    new-connection-mark=p2p_conn p2p=all-p2p passthrough=yes
    add action=mark-packet chain=prerouting connection-mark=p2p_conn disabled=no \
    new-packet-mark=p2p passthrough=yes
    add action=mark-packet chain=postrouting comment="regra cachefull" disabled=no \
    dscp=18 new-packet-mark=thunder_packs passthrough=yes
    add action=mark-connection chain=forward comment="Marca conexoes do Facebook" \
    content=facebook.com disabled=no new-connection-mark=facebook-conn \
    passthrough=yes
    add action=mark-packet chain=forward comment="Marca pacotes do Facebook" \
    connection-mark=facebook-conn disabled=no new-packet-mark=facebook-packs \
    passthrough=yes
    add action=mark-connection chain=forward comment="Marca conexoes do Orkut" \
    content=orkut.com disabled=no new-connection-mark=orkut-conn passthrough=\
    yes
    add action=mark-packet chain=forward comment="Marca pacotes do Orkut" \
    connection-mark=orkut-conn disabled=no new-packet-mark=orkut-packs \
    passthrough=yes
    add action=mark-connection chain=prerouting comment=P2P_IN disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

  2. #2
    Administrador Avatar de damao.tecnico
    Data de Ingresso
    Dec 2011
    Localização
    BRASIL
    Posts
    1,323
    Thanks (Given)
    36
    Thanks (Received)
    114
    Likes (Given)
    41
    Likes (Received)
    109
    Basicamente, o Mikrotik não consegue controlar pacotes criptografados (p2p e torrent). É uma limitação séria, inclusive. O que mais vejo por aí são profissionais tentando controlar banda desse tipo de conexão.

    Aparentemente, descobrindo-se quais portas se estão usando para essas conexões pode-se ter algum controle. Inclusive bloqueando. No próprio wiki da Mikrotik tem uma parte explicando sobre esse tratamento de pacotes criptografados.

    Se alguém tiver alguma solução perspicaz, não deixe de postar. Será de grande ajuda para TODOS. Inclusive, EU hehe.

    Abraço.

  3. #3
    Member
    Data de Ingresso
    Jul 2012
    Posts
    72
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    1
    descobrir as portas é complicado, pois o mesmo usa uma gama de portas para se conectar, se eu fizer um controle de QoS no cliente, o torrent tb entra na regra?
    eu ja vi que da pra bloquear, o que não seria legal..

    Citação Postado originalmente por damao.tecnico Ver Post
    Basicamente, o Mikrotik não consegue controlar pacotes criptografados (p2p e torrent). É uma limitação séria, inclusive. O que mais vejo por aí são profissionais tentando controlar banda desse tipo de conexão.

    Aparentemente, descobrindo-se quais portas se estão usando para essas conexões pode-se ter algum controle. Inclusive bloqueando. No próprio wiki da Mikrotik tem uma parte explicando sobre esse tratamento de pacotes criptografados.

    Se alguém tiver alguma solução perspicaz, não deixe de postar. Será de grande ajuda para TODOS. Inclusive, EU hehe.

    Abraço.

  4. #4
    Senior Member
    Data de Ingresso
    Aug 2012
    Posts
    164
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    0
    Citação Postado originalmente por damao.tecnico Ver Post
    Basicamente, o Mikrotik não consegue controlar pacotes criptografados (p2p e torrent). É uma limitação séria, inclusive. O que mais vejo por aí são profissionais tentando controlar banda desse tipo de conexão.

    Aparentemente, descobrindo-se quais portas se estão usando para essas conexões pode-se ter algum controle. Inclusive bloqueando. No próprio wiki da Mikrotik tem uma parte explicando sobre esse tratamento de pacotes criptografados.

    Se alguém tiver alguma solução perspicaz, não deixe de postar. Será de grande ajuda para TODOS. Inclusive, EU hehe.

    Abraço.

    ola amigo vc faz configuraçoes pra pequenos provedores como eu ? eu gostaria de reconfigura o meu mikrotik com um certa urgencia e inplementar Vlan na rede vc faz esse tipo de serviso ?

  5. #5
    Administrador Avatar de damao.tecnico
    Data de Ingresso
    Dec 2011
    Localização
    BRASIL
    Posts
    1,323
    Thanks (Given)
    36
    Thanks (Received)
    114
    Likes (Given)
    41
    Likes (Received)
    109
    Citação Postado originalmente por kakarotojs Ver Post
    ola amigo vc faz configuraçoes pra pequenos provedores como eu ? eu gostaria de reconfigura o meu mikrotik com um certa urgencia e inplementar Vlan na rede vc faz esse tipo de serviso ?
    Amigo,

    Infelizmente não presto serviço de consultoria, apenas no meu provedor. Mas no fórum existem profissionais que fazem. Exemplo: o Norton Cabral, da Sixagência.

    Abraço.

  6. #6
    Moderador
    Data de Ingresso
    Aug 2011
    Localização
    RS, Brasil
    Posts
    1,094
    Thanks (Given)
    23
    Thanks (Received)
    38
    Likes (Given)
    16
    Likes (Received)
    33
    Mas a queue simple segura no plano designado pro cliente, não?
    Thunder em Paralelo+TProxy
    Intel 1200BTS + Xeon 3.10v2 + 8gb
    Sist.(80gb) + Cache(5x 1TB) WD Black e RE4

  7. #7
    Junior Member
    Data de Ingresso
    Aug 2014
    Posts
    5
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    0
    Bom dia a todos, aqui estou enfrentando o mesmo problema ja fiz diversas regras aqui diversas tentativas e não obtive eseto em nenhuma delas, recentemente apelei ate para o layer 7 e mais uma vez não obtive sucesso. SE ALGUÉM AI CONHECE ALGUMA MANEIRA QUE REALMENTE FUNCIONE POR FAVOR COMPARTILHE CONOSCO!!!

Marcadores

Marcadores

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •