Resultados 1 a 10 de 10

Tópico: Controle do Protocolo UDP (Download e Upload)

  1. #1
    Administrador Avatar de damao.tecnico
    Data de Ingresso
    Dec 2011
    Localização
    BRASIL
    Posts
    1,327
    Thanks (Given)
    36
    Thanks (Received)
    114
    Likes (Given)
    41
    Likes (Received)
    109

    Controle do Protocolo UDP (Download e Upload)

    Vários colegas de profissão vivem "quebrando" a cabeça tentando achar uma forma de impedir que conexões P2P e Warez "acabem" com suas redes. Bem, trocando umas idéias com o Mário Júnior, e baseado no que li em alguns fóruns, eis algumas regrinhas simples (deve haver outras formas de implementar, creio) que podem dar uma "brecada" nesses softwares malditos.

    Primeiramente em:
    Código:
    /ip firewall mangle
    Adicionar duas regras de marcação de pacotes (imagina como se fosse a marcação do P2P), marcando o protocolo UDP. Isso deve ser feito para cada rede. Exemplo: Se existe uma rede para o Hotspot e outra para o PPPoE, então repita as regras, mudando src-address e dst-address para as redes específicas.
    Código:
    add action=mark-packet chain=prerouting comment="Controle do Trafego UDP" disabled=no new-packet-mark=udp_Up_rede10 \
        passthrough=yes protocol=udp src-address=10.10.10.0/24
    
    add action=mark-packet chain=prerouting comment="" disabled=no dst-address=10.10.10.0/24 new-packet-mark=udp_Down_rede10 \
        passthrough=no protocol=udp
    Depois, criar as Queues para controlar as velocidades de Download/Upload do Protocolo UDP, baseado nas marcações anteriores:
    Código:
    /queue tree
    
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=UDP_Up_10 packet-mark=udp_Up_rede10 \
        parent=global-out priority=8 queue=default
    
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=2M name=UDP_Down_10 packet-mark=udp_Down_rede10 \
        parent=global-in priority=8 queue=default
    Limitei aqui o Download Máximo em 2 Mb e o Upload a 1 Mb para o Protocolo UDP. Vai ser "dividido" entre as estações da rede especificada.

    Ah, aceito sugestões e críticas, elas são muito bem-vindas. Aliás, toda crítica construtiva nos ajuda a melhorar sempre. Para mim essa solução funciona, mas cada realidade é diferente.

    Abraço a Todos.
    Última edição por damao.tecnico; 09-09-2012 às 11:14 PM.

  2. #2
    Senior Member
    Data de Ingresso
    Apr 2011
    Posts
    197
    Thanks (Given)
    0
    Thanks (Received)
    1
    Likes (Given)
    0
    Likes (Received)
    1
    o cabeçao bom dia.o galera ele e do ceara viuuuuuuuuuuuuuu.por isso tem essa mente san cabeça san. ta que e um mario junior kkkkkk.

  3. #3
    Senior Member
    Data de Ingresso
    Apr 2011
    Posts
    197
    Thanks (Given)
    0
    Thanks (Received)
    1
    Likes (Given)
    0
    Likes (Received)
    1
    e bom dia a todos. falando serio botamos estas regras aqui no meu servidor que tva dando pau toda hora prossesador e memoria la em cima travando ate o asseso meu ao wimbox agora meu prossesador nao passa de 50% em
    uma rb 750g. com 60 cliente valeu damiao nao v agradeçe pq te agradeço todo dia valeu Mario broder BRIGADAO.

  4. #4
    Senior Member Avatar de rick
    Data de Ingresso
    Jan 2011
    Posts
    292
    Thanks (Given)
    0
    Thanks (Received)
    3
    Likes (Given)
    0
    Likes (Received)
    2
    Parabens Damão pelo post.

  5. #5
    Administrador Avatar de damao.tecnico
    Data de Ingresso
    Dec 2011
    Localização
    BRASIL
    Posts
    1,327
    Thanks (Given)
    36
    Thanks (Received)
    114
    Likes (Given)
    41
    Likes (Received)
    109
    Citação Postado originalmente por rick Ver Post
    Parabens Damão pelo post.
    Obrigado mano, a idéia é ajudar os Compadres... Sempre! Me sinto feliz com atitudes como a sua!!! Vlw.

    Abraço.

  6. #6
    Junior Member
    Data de Ingresso
    Mar 2012
    Posts
    14
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    0
    Parabens... pelo poste meu caro amigo Damião. è de grande ajuda.

  7. #7
    Administrador Avatar de damao.tecnico
    Data de Ingresso
    Dec 2011
    Localização
    BRASIL
    Posts
    1,327
    Thanks (Given)
    36
    Thanks (Received)
    114
    Likes (Given)
    41
    Likes (Received)
    109
    Citação Postado originalmente por agnaldos Ver Post
    Parabens... pelo poste meu caro amigo Damião. è de grande ajuda.
    Vlw.

    Abraço

  8. #8
    Senior Member
    Data de Ingresso
    Feb 2012
    Posts
    122
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    1
    Likes (Received)
    2
    Damião, como sempre dando uma mão. parabéns amigo.Você sempre ajudando a outros que precisão, assim como já me ajudou bastante também.Obrigado amigo.

  9. #9
    Administrador Avatar de damao.tecnico
    Data de Ingresso
    Dec 2011
    Localização
    BRASIL
    Posts
    1,327
    Thanks (Given)
    36
    Thanks (Received)
    114
    Likes (Given)
    41
    Likes (Received)
    109
    Citação Postado originalmente por eletrosam Ver Post
    Damião, como sempre dando uma mão. parabéns amigo.Você sempre ajudando a outros que precisão, assim como já me ajudou bastante também.Obrigado amigo.
    Vlw.

  10. #10
    Banned
    Data de Ingresso
    Nov 2010
    Localização
    Barra Do Bugres MT, Brazil
    Posts
    805
    Thanks (Given)
    0
    Thanks (Received)
    5
    Likes (Given)
    2
    Likes (Received)
    6
    Citação Postado originalmente por damao.tecnico Ver Post
    Vários colegas de profissão vivem "quebrando" a cabeça tentando achar uma forma de impedir que conexões P2P e Warez "acabem" com suas redes. Bem, trocando umas idéias com o Mário Júnior, e baseado no que li em alguns fóruns, eis algumas regrinhas simples (deve haver outras formas de implementar, creio) que podem dar uma "brecada" nesses softwares malditos.

    Primeiramente em:
    Código:
    /ip firewall mangle
    Adicionar duas regras de marcação de pacotes (imagina como se fosse a marcação do P2P), marcando o protocolo UDP. Isso deve ser feito para cada rede. Exemplo: Se existe uma rede para o Hotspot e outra para o PPPoE, então repita as regras, mudando src-address e dst-address para as redes específicas.
    Código:
    add action=mark-packet chain=prerouting comment="Controle do Trafego UDP" disabled=no new-packet-mark=udp_Up_rede10 \
        passthrough=yes protocol=udp src-address=10.10.10.0/24
    
    add action=mark-packet chain=prerouting comment="" disabled=no dst-address=10.10.10.0/24 new-packet-mark=udp_Down_rede10 \
        passthrough=no protocol=udp
    Depois, criar as Queues para controlar as velocidades de Download/Upload do Protocolo UDP, baseado nas marcações anteriores:
    Código:
    /queue tree
    
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=UDP_Up_10 packet-mark=udp_Up_rede10 \
        parent=global-out priority=8 queue=default
    
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=2M name=UDP_Down_10 packet-mark=udp_Down_rede10 \
        parent=global-in priority=8 queue=default
    Limitei aqui o Download Máximo em 2 Mb e o Upload a 1 Mb para o Protocolo UDP. Vai ser "dividido" entre as estações da rede especificada.

    Ah, aceito sugestões e críticas, elas são muito bem-vindas. Aliás, toda crítica construtiva nos ajuda a melhorar sempre. Para mim essa solução funciona, mas cada realidade é diferente.

    Abraço a Todos.
    Aqui Uso Com PCQ Limito a quantia por cliente fica otimo, cada cliente tem o Limite de 100K de uso para P2P assim nao inforca a conexao.

Marcadores

Marcadores

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •