Página 3 de 3 PrimeiroPrimeiro 123
Resultados 21 a 26 de 26

Tópico: Unbound. DNS recursivo para seu Ubuntu/ThunderCache

  1. #21
    Senior Member Avatar de davidmilfont
    Data de Ingresso
    Dec 2010
    Localização
    Fortaleza/Ce
    Posts
    329
    Thanks (Given)
    41
    Thanks (Received)
    4
    Likes (Given)
    63
    Likes (Received)
    4
    Citação Postado originalmente por davidmilfont Ver Post
    Feito amigo,mas está ocorrendo um erro de portas eu acho...
    Removi umas linhas do unbound.conf, o erro sumiu e o comando "unbound-control stats" retornou.
    Agora sabe informar como eu tenho certeza que o server DNS tá funcionando normal?
    Obrigado pela atenção.

  2. #22
    Senior Member Avatar de Psergiocgr
    Data de Ingresso
    Sep 2010
    Localização
    Sidrolândia, Brazil
    Posts
    404
    Thanks (Given)
    0
    Thanks (Received)
    2
    Likes (Given)
    0
    Likes (Received)
    3
    Citação Postado originalmente por davidmilfont Ver Post
    Removi umas linhas do unbound.conf, o erro sumiu e o comando "unbound-control stats" retornou.
    Agora sabe informar como eu tenho certeza que o server DNS tá funcionando normal?
    Obrigado pela atenção.
    primeiro voce coloca o IP do seu server DNS e coloca no seu MK e no thunder em primeiro plano em seguida pelo putty abra o terminal e loga no seu linux faz o login e digite TOP no terminal e veja la se o unbound na no topo, é uma referencia que ta rodando blzinha

  3. #23
    Senior Member Avatar de Psergiocgr
    Data de Ingresso
    Sep 2010
    Localização
    Sidrolândia, Brazil
    Posts
    404
    Thanks (Given)
    0
    Thanks (Received)
    2
    Likes (Given)
    0
    Likes (Received)
    3
    pra quem precisa de uma ajuda pra montar seu server tai as configs. o meu aqui é Debian

    cat > /etc/unbound/unbound.conf <<-EOF
    server:
    access-control: 127.0.0.0/8 allow SERVER-DNS
    access-control: 172.16.0.0/16 allow CLIENTES PPPOE
    access-control: 192.168.10.0/24 allow THUNDERCACHE 7.1
    access-control: 10.1.1.1/29 allow SERVER-DNS
    auto-trust-anchor-file: "/var/lib/unbound/root.key"
    verbosity: 1
    statistics-interval: 120
    num-threads: 1
    interface: 0.0.0.0
    outgoing-range: 512
    num-queries-per-thread: 1024
    msg-cache-size: 16m
    rrset-cache-size: 32m
    msg-cache-slabs: 4
    rrset-cache-slabs: 4
    cache-max-ttl: 86400
    infra-host-ttl: 60
    infra-lame-ttl: 120
    infra-cache-numhosts: 10000
    infra-cache-lame-size: 10k
    do-ip4: yes
    do-ip6: no
    do-udp: yes
    do-tcp: yes
    do-daemonize: yes
    logfile: ""
    use-syslog: no
    identity: "DNS"
    version: "1.4"
    hide-identity: yes
    hide-version: yes
    harden-glue: yes
    do-not-query-address: 127.0.0.1/8
    do-not-query-localhost: yes
    module-config: "iterator"
    local-zone: "localhost." static
    local-data: "localhost. 10800 IN NS localhost."
    local-data: "localhost. 10800 IN SOA localhost. nobody.invalid. 1 3600 1200 604800 10800"
    local-data: "localhost. 10800 IN A 127.0.0.1"
    local-zone: "127.in-addr.arpa." static
    local-data: "127.in-addr.arpa. 10800 IN NS localhost."
    local-data: "127.in-addr.arpa. 10800 IN SOA localhost. nobody.invalid. 2 3600 1200 604800 10800"
    local-data: "1.0.0.127.in-addr.arpa. 10800 IN PTR localhost."
    local-zone: "ubuntuprecise.net." static
    local-data: "ubuntuprecise.net. 86400 IN NS ns1.ubuntuprecise.net."
    local-data: "ubuntuprecise.net. 86400 IN SOA ubuntuprecise.net. proxy.ubuntuprecise.net. 3 3600 1200 604800 86400"
    local-data: "ubuntuprecise.net. 86400 IN A 10.1.1.2"
    local-data: "www.ubuntuprecise.net. 86400 IN A 10.1.1.2"
    local-data: "ns1.ubuntuprecise.net. 86400 IN A 10.1.1.2"
    local-data: "mail.ubuntuprecise.net. 86400 IN A 10.1.1.2"
    local-data: "ubuntuprecise.net. 86400 IN MX 10 mail.ubuntuprecise.net."
    local-data: "ubuntuprecise.net. 86400 IN TXT v=spf1 a mx ~all"
    local-zone: "1.1.10.in-addr.arpa." static
    local-data: "1.1.10.in-addr.arpa. 10800 IN NS ubuntuprecise.net."
    local-data: "1.1.10.in-addr.arpa. 10800 IN SOA ubuntuprecise.net. proxy.ubuntuprecise.net. 4 3600 1200 604800 864000"
    local-data: "1.1.10.in-addr.arpa. 10800 IN PTR ubuntuprecise.net."
    forward-zone:
    name: "."
    forward-addr: 8.8.8.8
    forward-addr: 8.8.4.4
    forward-addr: 208.67.222.222
    forward-addr: 208.67.220.220
    remote-control:
    control-enable: yes
    control-interface: 127.0.0.1
    control-interface: 10.1.1.2
    control-port: 953
    server-key-file: "/etc/unbound/unbound_server.key"
    server-cert-file: "/etc/unbound/unbound_server.pem"
    control-key-file: "/etc/unbound/unbound_control.key"
    control-cert-file: "/etc/unbound/unbound_control.pem"
    EOF

    http://ubuntuserverguide.com/2012/10...ver-12-04.html
    Última edição por Psergiocgr; 07-31-2014 às 03:29 PM.

  4. Thanks davidmilfont thanked for this post
    Likes davidmilfont liked this post
  5. #24
    Senior Member Avatar de jean
    Data de Ingresso
    Oct 2013
    Localização
    Amazonas
    Posts
    186
    Thanks (Given)
    12
    Thanks (Received)
    10
    Likes (Given)
    21
    Likes (Received)
    9
    Uma Opinião!

    Só acho desnecessário essa parte:
    forward-zone:
    name: "." (esse campo vazio, está dizendo que o servidor deve usar pra todas solicitações o DNS listados abaixo, isso significa dizer que o unbound não vai estar fazendo (resolvendo) nada, o correto seria especificar quais domínios deveriam ser resolvidos pela lista a seguir. Exemplo name: "uol.com.br")
    forward-addr: 8.8.8.8
    forward-addr: 8.8.4.4
    forward-addr: 208.67.222.222
    forward-addr: 208.67.220.220

    Pelo fato de o unbound ja ter seus próprios forwards. Então é dispensável esses encaminhadores externos.


    Citação Postado originalmente por Psergiocgr Ver Post
    pra quem precisa de uma ajuda pra montar seu server tai as configs. o meu aqui é Debian

    cat > /etc/unbound/unbound.conf <<-EOF
    server:
    access-control: 127.0.0.0/8 allow SERVER-DNS
    access-control: 172.16.0.0/16 allow CLIENTES PPPOE
    access-control: 192.168.10.0/24 allow THUNDERCACHE 7.1
    access-control: 10.1.1.1/29 allow SERVER-DNS
    auto-trust-anchor-file: "/var/lib/unbound/root.key"
    verbosity: 1
    statistics-interval: 120
    num-threads: 1
    interface: 0.0.0.0
    outgoing-range: 512
    num-queries-per-thread: 1024
    msg-cache-size: 16m
    rrset-cache-size: 32m
    msg-cache-slabs: 4
    rrset-cache-slabs: 4
    cache-max-ttl: 86400
    infra-host-ttl: 60
    infra-lame-ttl: 120
    infra-cache-numhosts: 10000
    infra-cache-lame-size: 10k
    do-ip4: yes
    do-ip6: no
    do-udp: yes
    do-tcp: yes
    do-daemonize: yes
    logfile: ""
    use-syslog: no
    identity: "DNS"
    version: "1.4"
    hide-identity: yes
    hide-version: yes
    harden-glue: yes
    do-not-query-address: 127.0.0.1/8
    do-not-query-localhost: yes
    module-config: "iterator"
    local-zone: "localhost." static
    local-data: "localhost. 10800 IN NS localhost."
    local-data: "localhost. 10800 IN SOA localhost. nobody.invalid. 1 3600 1200 604800 10800"
    local-data: "localhost. 10800 IN A 127.0.0.1"
    local-zone: "127.in-addr.arpa." static
    local-data: "127.in-addr.arpa. 10800 IN NS localhost."
    local-data: "127.in-addr.arpa. 10800 IN SOA localhost. nobody.invalid. 2 3600 1200 604800 10800"
    local-data: "1.0.0.127.in-addr.arpa. 10800 IN PTR localhost."
    local-zone: "ubuntuprecise.net." static
    local-data: "ubuntuprecise.net. 86400 IN NS ns1.ubuntuprecise.net."
    local-data: "ubuntuprecise.net. 86400 IN SOA ubuntuprecise.net. proxy.ubuntuprecise.net. 3 3600 1200 604800 86400"
    local-data: "ubuntuprecise.net. 86400 IN A 10.1.1.2"
    local-data: "www.ubuntuprecise.net. 86400 IN A 10.1.1.2"
    local-data: "ns1.ubuntuprecise.net. 86400 IN A 10.1.1.2"
    local-data: "mail.ubuntuprecise.net. 86400 IN A 10.1.1.2"
    local-data: "ubuntuprecise.net. 86400 IN MX 10 mail.ubuntuprecise.net."
    local-data: "ubuntuprecise.net. 86400 IN TXT v=spf1 a mx ~all"
    local-zone: "1.1.10.in-addr.arpa." static
    local-data: "1.1.10.in-addr.arpa. 10800 IN NS ubuntuprecise.net."
    local-data: "1.1.10.in-addr.arpa. 10800 IN SOA ubuntuprecise.net. proxy.ubuntuprecise.net. 4 3600 1200 604800 864000"
    local-data: "1.1.10.in-addr.arpa. 10800 IN PTR ubuntuprecise.net."
    forward-zone:
    name: "."
    forward-addr: 8.8.8.8
    forward-addr: 8.8.4.4
    forward-addr: 208.67.222.222
    forward-addr: 208.67.220.220
    remote-control:
    control-enable: yes
    control-interface: 127.0.0.1
    control-interface: 10.1.1.2
    control-port: 953
    server-key-file: "/etc/unbound/unbound_server.key"
    server-cert-file: "/etc/unbound/unbound_server.pem"
    control-key-file: "/etc/unbound/unbound_control.key"
    control-cert-file: "/etc/unbound/unbound_control.pem"
    EOF

    http://ubuntuserverguide.com/2012/10...ver-12-04.html
    -jean silva-

  6. #25

  7. #26
    Senior Member
    Data de Ingresso
    Aug 2012
    Posts
    226
    Thanks (Given)
    0
    Thanks (Received)
    5
    Likes (Given)
    0
    Likes (Received)
    5
    Citação Postado originalmente por jean Ver Post
    Uma Opinião!

    Só acho desnecessário essa parte:
    forward-zone:
    name: "." (esse campo vazio, está dizendo que o servidor deve usar pra todas solicitações o DNS listados abaixo, isso significa dizer que o unbound não vai estar fazendo (resolvendo) nada, o correto seria especificar quais domínios deveriam ser resolvidos pela lista a seguir. Exemplo name: "uol.com.br")
    forward-addr: 8.8.8.8
    forward-addr: 8.8.4.4
    forward-addr: 208.67.222.222
    forward-addr: 208.67.220.220

    Pelo fato de o unbound ja ter seus próprios forwards. Então é dispensável esses encaminhadores externos.

    Ola! Sei que o tópico é antigo mas estou com um problema e vou relatar:
    Ja tenho o servidor dns unbound na rede e esta funcionando certo.
    Ocorre que contratei uns links da NOVAG1 e se direciono o servidor dns para um dos links dessa provedora o dns não funciona e não resolve mais.
    Eu usava um link da Oi para fornecer internet para o servidor dns e funcionava certinho mas se direciono para os da novag1 o dns não resolve mais nada.

    Uso uma configuração de dns que o amigo Damão me forneceu e sempre funcionou(abaixo) no link adsl da Oi velox.
    O pessoal da novag1 aqui de Sinop-MT não sabe o que pode ser, ja colocaram em ppoe e em automatico mas nada do meu server dns resolver.
    Ja disse que no equipamento deles não pode ter o ip de servidor dns da operadora e disseram que tiraram mas mesmo assim o meu unboud dns não resolve nada se direciono para o link da novag1.

    Me ajudem please!

    Minha config que está funcionando.

    # Configuracao basica gerada no momento da ativacao do servidor
    server:
    port: 53
    username: unbound
    directory: /var/unbound
    chroot: /var/unbound
    use-syslog: yes
    logfile: /var/unbound/unbound.log
    pidfile: /var/run/local_unbound.pid
    auto-trust-anchor-file: /var/unbound/root.key
    #
    # Configuracao basica das redes atendidas pelo servidor
    #
    interface: 127.0.0.1
    interface: 192.168.0.9
    access-control: 0.0.0.0/0 refuse
    access-control: 127.0.0.0/8 allow
    access-control: 192.168.0.0/24 allow
    access-control: 177.38.236.0/24 allow
    access-control: 192.168.2.0/24 allow
    access-control: 2.2.2.2/32 allow
    access-control: 10.1.1.1/29 allow
    #
    #Tunning do site do unbound
    # with forked operation
    do-ip6: no
    do-ip4: yes
    do-tcp: yes
    do-udp: yes
    do-daemonize: yes
    verbosity: 1
    module-config: "iterator"
    msg-cache-slabs: 2
    rrset-cache-slabs: 2
    infra-cache-slabs: 2
    key-cache-slabs: 2


    # mais cache em memoria, rrset=msg*2
    # total usavel eh 150m*cores
    rrset-cache-size: 100m
    msg-cache-size: 50m

    #
    # Eventuais problemas de fragmentation de pacotes
    edns-buffer-size: 1490
    #

    #Exemplo de como Definir uma zona
    #local-zone:"localweb.com." static
    #local-data:"www.localweb.com. 10800 IN A 192.168.0.10"
    #
    #
    #
    #include: /var/unbound/forward.conf

    # Exemplo de como ativar o unbound-control
    # remote-control:
    # control-enable: yes

    Obrigado!

Página 3 de 3 PrimeiroPrimeiro 123

Marcadores

Marcadores

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •